Black Ops II Will Not Support Windows XP

Please don’t point that shotgun at my face, dear Windows XP users. It is confirmed by the Call of Duty FAQ itself that the game is not compatible with Windows XP. The reason: Game runs fully on Direct X11.

[ad#Google Adsense 336×280]

Here are the official Minimum Requirements.

What are the Minimum System Requirements?

OS: Windows Vista SP2 or Windows 7
CPU: Intel Core2 Duo E8200 2.66 GHz or AMD Phenom X3 8750 2.4 GHz
Memory: 2GB for 32-bit OS or 4GB for 64-bit OS
Video Card: Nvidia GeForce 8800GT 512 MB or ATI Radeon HD 3870 512 MB

Author’s Note: Don’t be surprised and please put down the shotgun. There are already quite a number of games in the market like Sleeping Dogs that are going through this “upgrade”. Maybe it’s time to upgrade the OS, XP is like a walking T-Rex fossil now. I must sincerely admit that it will always be one of my favorite OS’ though.

Source: CallofDuty

READ ALSO  Blast From the Past: Sid Meier’s Colonization (1994)
  • Show Comments

Your email address will not be published. Required fields are marked *

comment *

  • name *

  • email *

  • website *

This site uses Akismet to reduce spam. Learn how your comment data is processed.